Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

Windows 10 activation

I'm trying to activate Windows 10, I have tried it via cmd step ("slmgr.vbs -ipk xxxxx-xxxxx-xxxxx-xxxxx-xxxxx"), than via install step(created bat file), and at the end via cmd step where I was "calling" bat file ("CALL "file.bat""). In every single try Windows is actually activated, BUT status in deploy procces is stock on "Running". It frustrate me because I have nested package and when procces stock on this step it didn't allow to continue with rest.




Date Votes
  • I've got ours setup as a command-prompt task, running like such:

    c:\windows\system32\cscript //B c:\windows\system32\slmgr.vbs

    Which seems to work fine.

  • I'm not sure if it helps in your situation but have you looked into Microsoft VAMT, it's a free utility from MS to manage Windows/Office licensing for networked systems. Supports right click activate and will return available uses of MAK / store KMS keys etc.

  • I have only OEM BIOS keys so I run in Deploy:

    Set-ExecutionPolicy Bypass -Force
    $ProductKey = (Get-WmiObject -Class SoftwareLicensingService).OA3xOriginalProductKey
    iex "cscript /b C:\Windows\System32\slmgr.vbs -ipk $Productkey" 
    Start-Sleep 5
    iex "cscript /b C:\Windows\System32\slmgr.vbs -ato"

    Then also restart winExplorer

    Stop-Process -Name explorer -force