Important Notice: On February 29th, this community will be put into read-only mode. All existing posts will remain but customers will be unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

Anyone have luck deploying Bartender?

Trying to setup a deploy package for Bartender 10.0 across 50 computers.

0

Comments

17 comments
Date Votes
  • We tryed it Today and got it running (I know the Post is 2 Years old, but maybe anyone needs the Info)

    Parameters: /s /v" ADDLOCAL=BarTender INSTALLSQL=true

    and Include Entrire Directory.

     

    1
  • Hello,

    Bartender 2021 R8

    Finaly found 2 method to succesfully install it trought PDQ.

    1- INSTALL

    *** OPTIONS ***

    2- PWS

    *** OPTIONS ***

     

    1
  • Need more information:

    1. MSI or EXE?
    2. Silent installation options provided by developer?
    3. Any managed installation documentation from developer?
    0
  • It is an .exe file Link to software and the Silent Install Guide is posted below. Keep getting error code 1603 and it looks like it installs partially but I have to run a repair on it before it works on the computer.

    0
  • This documentation seems......off. A lot of those switches are used for MSI installs, not .exe. Example: /qn I'd be curious to hear how a silent installs works when run manually on a local machine.

    0
  • Hi I'm wondering if you guys had any luck with this? I too am trying to deploy BarTender 2016. Following the guide from Seagull posted by Schlep and used the following command;

    BT2016_R8_3153_full.exe FEATURE=BarTender BLS=XXX.XXX.XXX.XXX:XXX PKC=XXXX-XXXX-XXXX-XXXX

    However in PDQ Deploy it just hangs on install until after 15 min. I aborted the install.

    0
  • Thanks Dirk,

    I will be testing this deploy soon.

    0
  • I'm trying (unsuccessfully) to get this working with BarTender 2021 R8.

    When I copy the .exe to the desktop of my test PC and I run the following Powershell command, the command completes within a minute or so, and it takes an additional 10 minutes for the install to completely finish as seen in task manager background processes.

    .\BT2021_R8_177370_Full_x64.exe FEATURE=BarTender INSTALLSQL=False BLS=LicenseServer:5160

    Two things do not occur in this scenario:
    1) No desktop shortcut
    2) BT doesn't register on first launch, you have to "search the network for a license" then pick the license from the aforementioned license server, then it is registered. Not a huge deal but just annoying since it was specified in the command line.

    Reference for Silent Install on 2019+

    When I try to do a Powershell script step in PDQ (with the same command as above) it will run for about 1 minute then says successful - but nothing is installed on the test PC. I also notice when the command finishes, it opens System32 in File Explorer. Weird.

    When I try to do an install step in PDQ it will run for 2 minutes then say successful - again the same symptoms as above with file explorer opening and nothing being installed. I am also including the entire directory where it is stored on a NAS server (full access to everyone) and I tried run as deploy user (domain admin) and local system, with same results occurring.

    The install step command line looks like this:

    BT2021_R8_177370_Full_x64.exe FEATURE=BarTender INSTALLSQL=False BLS=LicenseServer:5160

    If you want to download BT to try to help out, you do not need a license to install it - just to launch and use it. As long as it gets installed successfully is all I am aiming for.

    BarTender Latest Version

     

    0
  • GottaLovePDQ

    please try the following:

    Install Step > Install File your .exe File (with UNC Path)

    under Parameters

    /s /v" ADDLOCAL=BarTender INSTALLSQL=false BLS=LicenseServer:5160

    and Include Entire Directory has to be set.

     

    0
  • Hi Dirk,

    Thank you for the prompt reply. I did try following your previous comment and I have the install file set as full UNC path, and I am including entire directory. The parameters you suggested are not valid for BarTender versions 2019 and up. The silent install parameters can be found here.

    https://www.seagullscientific.com/media/1677/bartender-silent-install-201908.pdf 

    (/s /v /qn will return an error if run locally, and ADDLOCAL has changed to FEATURE)

    0
  • Sorry for that, nice to know that they changed it.

     

    0
  • No problem. I just wish they kept things the same because apparently it was working for you on 2016 and now the same process doesn't work on 2021. Luckily I only have 6 computers that use the software so if I had to do it manually which seems like I might need to anyways because of the registration portion not working regardless... it's not a huge deal. But it would be nice to get it working properly and anyone else in the future having deployment issues with BT can reference this thread.

    0
  • Just an update as I was working on this today.

    BarTender versions 2019 and 2021 will not install through PDQ in any way I've tried. CMD, Powershell, or Install step. When doing it through PDQ it will only partially install to the point that it's in add/remove programs, but no files existed in Program Files. You cannot repair the software or run it, you can just remove it.

    If I am on the local machine I can run the following Powershell or CMD command to install with no issues. 

    \\Full\UNC\Path\To\EXE\BT2021_R8_177370_Full_x64.exe FEATURE=BarTender INSTALLSQL=False BLS=LicenseServer:5160

    However, I AM able to install version 2016 through PDQ without problems, either through install step, Powershell, or CMD. (Following Dirk Buender's suggestion for deployment)

    If you read documentation on their website, it says you CAN extract the .msi from the 2016 EXE if you want to deploy it that way, although it seems unnecessary as it deploys fine as an EXE. Then it goes on to say versions 2019 and higher can still extract the .msi, but you need to use the full EXE instead if you want silent parameters for install. I have not extracted the .msi out of either EXE, I might try that tomorrow as I'm not looking to install SQL or any other features in BarTender other than the main software itself. Either way it seems that they did something since version 2019 where it doesn't like PDQ for whatever reason.

    0
  • I've tried too over the last couple of years and have never been able to get it to install through Deploy. I thought I might get lucky with BarTender 2022, but still no luck.

    Since we use a KACE appliance for help desk, asset management, and security patches, I deploy BarTender using that. No tricks, just what they outline in the documentation and it works flawlessly. I hate deploying software with the KACE and BarTender is the only application I use it for.

    Sure with I could get it installed with PDQ Deploy!

    0
  • Hi Philippe Waltz

    I've tried exactly these two methods when previously attempting to deploy BT. It appears you are using the same version (177370) but mine has _x64 at the end. Perhaps you're trying with the 32-bit application? I try to avoid using 32-bit when possible but will attempt with that version.

    It also appears 2021 R9 is out, and so is 2022 R2, so I will test those as well.

    Quick Update: I can no longer obtain 2021 R8 32-bit to test. Behavior seems to be the same on 2021 R9 32-bit using PowerShell. Different result using install step. 2022 does not have a 32-bit version of the application and I won't try to do the 64-bit again.

    POWERSHELL (failed)


    It will partially install on target and in PDQ it will say it was successful after less than 1 minute. Then a BT process runs on the target machine for a couple more minutes. Once it finishes (you will see in task manager details tab the process BT isn't running) it is only partially installed with some files in C:\Program Files (x86) but the only 2 executable files are Register.exe and BtSystem.Service.exe and you can't launch BarTender. It exists in Add/Remove programs but not on desktop or start menu. There are also no Bartender services installed (there should be 4)

    INSTALL STEP (success w/ 32-bit)


    Similar process but the actual deploy takes a bit longer, it takes several minutes (8 minutes for my environment). You'll notice 2-3 different BT.exe's running on the details tab in task manager. Start menu shortcuts are created. System services are created (all 4 of them). PDQ will show it as running the entire length of the deployment then report success. No desktop shortcut, but I can launch BT Designer and it finds my license server with no issues. This is the extent of this test, I have not used bartender after deploying it this way, nor have I printed any labels as a test.

    I will try with 64-bit and see if it behaves the same.

    (update) Yes it works to deploy both 32-bit and 64-bit using the Install Step in PDQ provided that you are using Deploy User Interactive.

    0
  • Hello GottaLovePDQ,

    Glad it did work.

    I first tried Locally with PWS(Admin) and it did work.

    So, I tough it could be just some minor ajustment in PDQ.  So by playing around, I finally was able to push it with PDQ.  But, you are correct, it takes a minute to say it is successfull. Wich is partly true.  The lunch of the installation is successfull, but it seam that it cannot see the completion of the installation.  But at the end, it does install it with all options.

    Now, lunching this on 270 PC's, that was not very acceptable.  So I began to look at the Installation option and finaly found a way to do it.  On a some occation it would indicate failed, but the installation was completed. (Slower or older PC's perhaps...?)

     

     

    0
  • Awesome. I can confirm using Run As Deploy User (Interactive) works with 2022 R2. That's the one setting I never thought to try. The user will get a couple of windows pop up, but they are very brief and don't require any interaction.

    0

Please sign in to leave a comment.

Didn't find what you were looking for?

New post