Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

Help with PowerShell Script

If I run my ps1 script on the PC as the user manually I get no errors.

If I run it with PDQ Deploy it's throwing an exception, most of the script runs but then errors at some point.

At C:\WINDOWS\AdminArsenal\PDQDeployRunner\service-1\exec\Error Handling Wrapper.ps1:47 char:2
+     Throw $_.Exception.ErrorRecord
+     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo          : OperationStopped: (:) [], RuntimeException
+ FullyQualifiedErrorId : ScriptHalted

Anybody have any idea why it would do this? I get 0 errors when running it manually.



Date Votes
  • Can you try running it from the users computer using the login credentials you have setup for PDQ?

  • This script does not require any admin priv, I can run it as the user no problem. I an running it as the logged in user

  • What is the script trying to do at the point it fails?

    Add some logging of your own to your script and have it dump it to C:, so you can see what happens.