Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

High CPU with PDQInventory

I'm doing the 14 day evaluation with PDQ Inventory on a VMWare virtual server with 8gb of ram and 1 cpu. The problem I'm having is the CPU is spiking to 99% constantly. Task Manager reports the PDQInventory Service at 93-95% CPU. It's been 24 hours since I've initially scanned all the computers and I'm still seeing the problem. Computers seemed to scan successfully.

Is there anything you would advise me to do to help with the performance? So far I like PDQ Inventory, but I really need to get this performance issue solved before we can actually use it in our organization.

Thank you for your help.



Date Votes
  • Did you deploy the agent?

  • No, I haven't deployed any agents on any client computers. I did the full local install of PDQ Inventory and PDQ Deploy on the same computer. Forgot to mention that it is a Win 2012 R2 64 bit server.

  • Give it another vCPU

    Do you know what PDQ is doing with the CPU? It generally indicates at bottom of screen whats happening (scans etc)

  • Add at least one more cpu. I would also double check that agents didn't get installed by mistake or something like that. We had this exact issue and found the agent to be the main cause.

  • I added one more vCPU and that helped, but it still doesn't seem right. The PDQ Inventory Service is spiking from 3% to 50% CPU every few seconds.

    Before adding the second vCPU, it would stay at 97-100% CPU.

    It also say's "0 computers scanning." I also checked to verify that no agents have been deployed by adding the "Agent Version, Agent Status, and Agent Last Seen" columns to the "All Computers" grid.

    Under "All Computers" it shows 843 computers.

  • What version of .NET are you running ?

    Have you tried disabling anti-virus on your VM ?

  • Yes, I removed the Eset antivirus and we are running v4.0.30319. Add/Remove Programs says Microsoft .NET Framework 4 Multi-Targeting Pack

  • I ended up moving PDQ Inventory and PDQ Deploy to another server and it is running much better now. I guess there was something else going on with that server? Oh well, thanks for helping everyone!