Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

PDQ Inventory not resolving hostnames any more?


PDQ Inventory was working fine, but has stopped being able to resolve hostnames.

LAN is simple, basic router, no WINS, no DNS, no domain, just a simple stand-alone setup

Suspect a windows update changed something? All PCs latest Windows 10. All machines "fresh and clean" with the necessary firewall settings for PDQ.

The computer CAN resolve hostnames from the command prompt "e.g. ping PC2" will resolve IPv4 address. UNC from PDQ machine to any PC works fine etc.

PDQ tool, RDP and event viewer work fine, but manage with MMC does not (though if run compmgmt manually, and then connect to remote PC that works).

Adding a remote PC hostname/IP to the hosts file - and everything starts working (!) for that PC.


  • Its NOT firewall related on local or remote hosts
  • Its NOT remote host related
  • Adding hostname/IP to local hosts on PDQ machine and it works fine
  • Hostnames DO resolve from command prompt.
  • If machine is removed from PDQ and re-added, we get a green tick on host name resolution on the add box, but then does not resolve for scanning/heartbeat

Its as if PDQ is now using DNS to resolve the hostname (which is router DNS, so internet only - no LAN resolution) - and it checks hosts file - but does not check NETBIOS cache or try NetBIOS name resolution.

As mentioned, it did work since install till a couple of months ago.

I don't really want to give things fixed IP and add them to the hosts file lol - so any ideas?

(I don't think its a PDQ issue - but hope someone here had the same and can help)

Thanks 😃



Date Votes
  • The timeline sounds similar to the issues we are seeing. I think the problem came around the time of the introduction of the Inventory Agent in version 16. Prior to that we didn't have any problems with heartbeat / waking / restart & shutdown commands. Can we get confirmation PDQ isn't checking NETBIOS?

  • I have found lately that PDQ will just ignore completely any host files entries. Which is very frustrating as that was always my workaround to contact remote PCs that are on VPN - which for us often has DNS issues. Covid19 has exasperated this issues, as now everyone is on VPN.

  • Just an update on this issue for us.  We adopted Dynamic DNS and allow our pcs to register themselves on the DNS.  After doing that it cleaned up the majority of our problems resolving hostnames.  

  • Can we get an answer from PDQ on this? Highly frustrating that we can't utilize host files in emergency situations anymore. 

    With Covid everyone is still working off VPN, which is often not friendly with DNS. And historically host files have always been our saving grace in situations like this. But now there is no way to connect to a remote PC even if I know the IP address. Even if I hardcode the IP address in the host file on the central server, flush DNS, restart the PDQ services, PDQ still ignores the host file. The host file is supposed to the MASTER of hostname translation. Why is it being ignored?

    And to reply to Jim. Yeah, Dynamic DNS is the first thing that should be implemented.

  • I am unable to replicate this issue in If you can, please share a redacted version of your hosts file.

  • Hey Colby, thanks for chiming in!

    Just by your message, I see I'm a version or two behind. I'll update to see if that helps.  I've tried to squeeze as much helpful info as I could into one screenshot. 
    This is a central server, and for now, while troubleshooting this I'm using the console on the server (not remotely connecting from a workstation). 
    Server 2012 R2
    PDQ (Edit: It looks like this IS the latest version)

    I've updated the host file (with a tab between the IP and hostname). The underlying OS picks up on this change just fine, and I'm able to ping the hostname just fine. It's resolving the IP in the host file, and bypassing Windows/AD DNS. All is good thus far. 

    But in PDQ, it's not picking up on the change. For good measure, I'll flush the DNS cache, restart the DNS Client service, and restart both PDQ services. All to no avail, PDQ is still picking up the stale IP from AD DNS, and not the host file. 

    Yes... I know I should have a perfectly working DNS system for PDQ to work. That would be ideal and great in a perfect world. But we're a global company with about 60,000 endpoints. DNS is managed by an entirely separate team, I can't touch DNS. I'm just a sole SysAdmin at a site of about 40 users. Yes, they are aware that their Cisco ASA VPN DHCP server is not properly dynamically updating DNS when handing out DHCP leases to remote VPN clients. But it's a slow-moving process at a company this size. Nothing happens overnight, it takes months. 

    EDIT, direct link to screenshot, as it seems this forum compresses it and makes it a little hard to read the fine text:

  • Sorry, I forgot to mention that is the current Beta. However, we've changed some stuff under the hood recently, so if you can, please try out the Beta to see if it helps.

  • Inventory Beta did not change anything. (And note I did not update Deploy to the beta).
    Restarting the server had no effect.
    Any cached files/settings I should purge?

    It seems you feel that the host file should be honored, correct?

  • Aha, I think I may have found something. I had both the short name and the FQDN in my test hosts file. Try changing your hosts file entry to the FQDN. You can include both, but it looks like the short name is unnecessary.

  • OMG, great idea. I'll check that out. 

  • Boom. FQDN is the golden ticket!!!!  It updated the IP in the console after I forced a heartbeat. 

    Bravo! Thanks!  I really should have thought to have tried that. This is gonna save me tons of time in the future.