Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.


Skype 8 package times out when "Skype Meetings App" is installed

I noticed when I'm using the Skype 8 package to upgrade Skype 7 machines, the uninstall PowerShell gets hung up when Skype Meetings App is installed along with Skype. I looked at the script and saw it had an exclusion for Skype for Business but not Skype Meetings App. I added that condition to the script and the upgrade worked on those machines.

Can we have that exclusion added to the library package?

Modified uninstall script below (as of package version 8.3.8):

#Uninstalls Skype 7 or lower

$AppName = "Skype*"
$CurrentVersion = 8

Get-Process | Where-Object { $_.Name -contains "Skype" } | Stop-Process -Force -Verbose

ForEach ( $Architecture in "SOFTWARE", "SOFTWARE\Wow6432Node" ) #check 32 and 64 bit
	$UninstallKeys = "HKLM:\$Architecture\Microsoft\Windows\CurrentVersion\Uninstall" #Full uninstall registry path
	if (Test-path $UninstallKeys)
		$AppUninstall = Get-ItemProperty -Path "$UninstallKeys\*" | Where-Object -FilterScript { ($_.DisplayName -notlike "Skype for*") -and ($_.DisplayName -notlike "Skype Meeting*") -and ($_.DisplayName -like $AppName) -and ($_.DisplayVersion -lt $CurrentVersion) }
		$AppUninstallString = $AppUninstall | select-object PSChildName -ExpandProperty PSChildName #Get MSI guid

		If ( $AppUninstall -ne $null ) {
			$AppUninstallString | ForEach-Object {
				Write-Output "`r`nUninstalling: $($AppUninstall.DisplayName)" 
				Start-Process -Wait -FilePath "MsiExec.exe" -ArgumentList "/X$AppUninstallString /qn /norestart" #Uninstall guid using MsiExec
		} Else { 
			Write-Output "`r`n$AppName installation not found in: $UninstallKeys"
# SIG # Begin signature block - excluding this


Date Votes
  • Thank you for reporting this! I have opened an internal bug ticket.

  • Thanks Colby!

    I just came across another Skype-related program that's causing the uninstall script to stall: "Skype Web Plugin". So you should probably add an exclusion for that as well.

  • And another one! "Skype Click to Call"

    I ran a report, that should be the last. At least in my environment (for now).