Cross Domain Deployment

Hopefully someone can help.

We have 2 domains in our environment = *Domain A, Domain B

Domain A has the PDQ Deploy software on. The PDQ background service is set with a "Domain A" user account .

Domain B has my user account on it, which is a "Domain Admin", which in turn is a local admin of the Windows 7 machines.

When trying do deploy from PDQ using my Domain B Credentials it comes back "Access denied to computers service manager".

  • I'm able to browse to the \C$ on the machine and have access to the \Admin$.
  • I've tried changing the background service account on the Deploy Server to "Domain B" credentials but this doesn't work.
  • I can manually install the software.

Any thoughts or advice would be greatly appreciated.



Date Votes
  • Hi Maverick

    I'm not sure why this isn't working for you, we are able to manage computers in a different domain (no domain/forest trust) that are connected to our network via VPN. The method we used is the one you've described.

    Have you tried adding the credentials to PDQ Deploy, and then test deploying a package, and when you do the test deploy you can as a one off change the credentials used to the ones required by Domain B?

  • I am having an issue with this as well.

    Domain A: Primary local with PDQ INV/DEP installed Domain B: Remote

    0: B (NT 5) (Direct Outbound) (Direct Inbound) ( Attr: 0x8 ) 1: A (NT 5) (Forest Tree Root) (Primary Domain) (Native)

    Everything works fine on domain A but no matter what credentials I use on domain B it will not scan correctly.

  • Same here. I have the change the default credentials to the other domain to get the scan to work. It seems as though PDQI isn't trying the other credentials at all.

    EDIT: I found that you can select a machine, or multiple machines, right click and select scan user. You can change the credentials for the domain in question and everything works.


Please sign in to leave a comment.

Didn't find what you were looking for?

New post