Can't install ClickShare app with PDQ Deploy

I am able to install the ClickShare app successfully by running this line from a Command Prompt on my local computer.

msiexec.exe /I [folder path]\ClickShare_Installer.msi /QN ACCEPT_EULA=YES

However, when I use this same line in PDQ Deploy as either a Command or Install step it does not work. The job shows successful with Return Code 0, but no software is installed. The Output Log simply shows the syntax of the command line when running as a Command step.

There is more in the Output Log if it is run as an Install step. I don't see a way to attached the Output Log to this post, but some of the key lines are as follows.

WixQuietExec: ERROR: The process "clickshare.exe" not found. WixQuietExec: Error 0x80070080: Command line returned an error. WixQuietExec: Error 0x80070080: QuietExec Failed WixQuietExec: Error 0x80070080: Failed in ExecCommon method

Please advise how I should tweak the deploy job. Thanks.



Date Votes
  • If you are running the exact same command line in PDQ Deploy as you are locally, PDQ Deploy probably can't access the same location when the file resides. Put the file in the repository, then select that file when you build the package.

  • The MSI is in the same folder as the other setup files and all reside on the PDQ server. When I install it from my computer I am actually using UNC path to call the MSI from the PDQ server.

  • My next guess would be permissions on the file itself. Does the deploy credentials you are using have permissions to the file in question? Can you use those credentials when you test the installation locally?

  • Same credentials we use for all PDQ deployments, a domain admin account which also was the account used on the PDQ server when the installation files were placed there, so it has full permissions on files and folder.

    I also tried running the command line while logged on as this same domain account and the installation was successful.

  • We run ours as an "install" step, rather than command line, since it's intended for MSI files. Install file points to the network location of the MSI file.


    MSI options: Operation:Install Restart:Never Quiet:Yes

    Resulting command line field: msiexec.exe /i "ClickShare-Extension-Pack-" ALLUSERS=1 /qn /norestart /log output.log ACCEPT_EULA=YES LAUNCH_APP=YES

    It's worked about 400 times so far.

  • Strange. Running as an Install step with the exact syntax you suggest works for ClickShare Extension Pack but fails for ClickShare Installer. However, I am fine with this solution because the extension pack is a super set including the standard ClickShare. Thanks for all the replies.


Please sign in to leave a comment.

Didn't find what you were looking for?

New post