PDQ Deploy Enterprise "Add-WindowsCapability"

Answered

Comments

5 comments

  • Brad McClave

    What happens when you run it manually from one of those machines using any of the credentials you used to test the deployment?

    0
    Comment actions Permalink
  • Wei

    This is a known issue.

    The workaround is Change the following reg key value to 0 from 1

    \HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU\UseWUServer

    reboot -> run Add-WindowsCapability -Online -Name OpenSSH.Server~~~~0.0.1.0 -> Change the reg key value back to 1 -> reboot

    0
    Comment actions Permalink
  • William Sandler

    @Brodiemac It works fine when run manually/locally on the systems.

    @Wei Can you explain what affect that has on this? I have tried with machines that are both connected to and not connected to our WSUS server, with the same results.

    0
    Comment actions Permalink
  • Wei

    Check the event viewer of your target, see if there are any "1001" events ( under Windows Logs -> Application). It should tell you why Add-WindowsCapability failed.
    https://github.com/MicrosoftDocs/windowsserverdocs/issues/2074

    0
    Comment actions Permalink
  • William Sandler

    @Wei you were actually correct.

    Fixed with GPO:

    Computer Configuration > Administrative Templates > System > Specify settings for optional component installation and component repair > Contact Windows Update directly
    
    0
    Comment actions Permalink

Please sign in to leave a comment.