Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

PDQ Deploy - Waiting for Agent

Something I ran into today and thought I'd share.

I created a package, inside said package is our basic deployment for all our workstations (IE Chrome, Firefox, VLC, etc...). A few days ago I started working on a deployment package for our developer systems (Stuff like JDK8, JDK11, etc to custom directories) and put it in the same folder as the existing package. I renamed the existing one to match up "Windows 10 - Baseline" and "Windows 10 - Developer Baseline". Simple stuff really.

So here's where the problem started. We got a new laptop for a user yesterday and my desktop guy kept trying to deploy the baseline package and it would just sit at "Waiting for agent". Restarted the guest, PDQ several times, made sure it could connect, reinstalled the agent, everything I could think of. I then deployed another package manually for "testing" purposes and it worked. So then I thought, what was changed... simply renaming "Baseline Deployment" package to "Windows 10 - Baseline" couldn't have been the issue could it?

So I took a screenshot of all my 14 nested packages and deleted it. Recreated the package with the same name "Windows 10 - Baseline" and added all the nested packages and then hit deploy to find... it worked.

Figured I'd bring this up for anyone coming up with this similar issue.

  • PDQ Deploy:
  • PDQ Inventory:


Date Votes
  • Official comment

    We are announcing the End of Life (EOL) of the optional PDQ Agent beta from our existing products. See this blog post for more information

  • I know your problem, i had the same behaviour a few month ago. Your workaround is only a drop on a hot stone, the issue comes back soon because the problem is not the package, it's the agent itself.

    Look at: our young little agent is “still in beta”.

    My advice, remove the agent from all devices, he's not ready for a productive environment. All problems are gone since i removed the agent from our environment.

  • So if we are experiencing this issue and tried uninstalling the agent already what should we do to get it working? How do we revert back to another version?

  • Hi Community!

    are there solutions here now? We also have "Waiting for Agent" when we start the scan. we have already tried reinstalling the agent and restart all services did not help.

    I would appreciate an answer

    have a nice day,


  • I am also having this issue... Uninstalled agent and restarted services. Issue persists.

    Deploy -

    Inventory -

  • For those of you who have uninstalled the Agent and are still encountering (Waiting for Agent): did you use "Computer --> Uninstall Agent", or did you remove it a different way? It's important to use the Uninstall Agent menu option because that cleans up the Inventory database.