Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

Issue with PowerShell and PDQ Deploy 18.1?

So I haven't had much luck getting this to work with PDQ 18.1.  I just had a new PDQ server built for me for what I'm working on and it's not working.  I'm asking it to run certain PowerShell commands to the target machines, like installing a PowerShell module.  This worked a couple weeks ago with PDQ Deploy 17 (I think that's the correct version).  It was great.  We got a new license and are using 18.1.  What I'm using is in a different environment. 

The PDQ server is running on Windows Server 2019 with the latest updates, running PDQ 18.1.
The target machines are also running Server 2019.
The commands when run from PDQ show successful, but I don't get the results I want.  In fact nothing happened.
If I run a command in the package deploy using a cmd prompt step it will start the service I want (Windows Update), but then the PowerShell step still fails.

When I ran this a couple weeks ago it was on a different PDQ server.

Server was running Windows Server 2016 with PDQ Deploy 17.
Target machines were also running Server 2016.
Everything worked great.  PowerShell steps ran and it was glorious.
PDQ machine was recently upgraded to 18.1.  Now those same commands don't work at all.

PSRemoting, firewall, GPO that all seems to be fine and in working order.  ExecutionPolicy is set to RemoteSigned on both server OSes.  I can run the commands I'm trying to run on the target machines and they work, copy files to the target location works, etc.

This is very frustrating. I have machines I need to update on Friday and was really hoping to use PDQ Deploy for this, but it seems like that might not happen here.  I'd have to have someone re-download the previous versions of PDQ Deploy for me to try again, but I'd like to think there's something else that's a problem and not a new release of PDQ that's breaking stuff, unless I'm wrong there.

Please help.  All help appreciated.  Thanks in advance.



Date Votes
  • So on my new PDQ server (Running Server 2019) I uninstalled PDQ 18.1 and reverted back to 17.1.  Everything worked right away, aside from me having to change one part in the PowerShell setup to find the Windows Update service by the service name of wuauserv instead of looking for the DisplayName of "Windows Update".  I spoke to someone this morning who was using the original PDQ setup on Server 2016 that was upgraded to 18.1 and his scripts are running fine.  Those scripts are similar to mine in getting the Windows Updates and putting them into a text file, so none of this makes sense to me then.  Anybody have any ideas?  I'd like to upgrade to the latest release, but don't see a reason to if I'm going to have problems.

  • If you haven't already, please reach out to PowerShell should definitely be working in 18.1.