Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

PDQ Inventory 18.1 check for new version failed

Getting a failure notice when PDQ Inventory checks for a new version while running/at startup.

Just installed the 18.x update a few minutes ago, have tried restarting the program a couple of times.

Anyone else seeing this?



Date Votes
  • If this is still happening to you, please reach out to The update check is working on our end.

  • Shon, are you using a proxy, perhaps?

    I have the same problem.

  • My issue ended up being I needed to whitelist in my web filter, it was being blocked.

  • I too have this problem - With BOTH PDQ Inventory and PDQ Deploy :-/
    The issue came, when I updated from 17.x to 18.1 (Inventory and Deploy)...

    And now all my packages in PDQ Inventory - that should get autoapproved within the next 7 days - have/get a red circle and an exclamation mark inside... ??? (probably caused by the same connection issue...)

    NB: For this version update, I had to run the installers (Inventory & Deploy) manually - beforehand the updates could be initated from within the programs (as far as I remember)

  • Torben Hauge

    Please update to It contains fixes for a couple of bugs that can cause this issue. If it doesn't fix the issue, please contact

  • Thank you, Colby.  I was having the same issue and your links worked for me.

  • Thank you, Colby Bouma !!!

    The update to did the trick :-)
    The warnings from both PDQ Inventory and PDQ Deploy are now gone + the packages are downloading; and the red exclamation mark disappears, when the downloads of each package is completed.

    Thanks for the very quick response !!!

  • I had the same issue and manually updating did not resolve the problem.  I added my server to "Internal Ignores" in our web filter and that did the trick.  I probably could have whitelisted "" as suggested above, but I just decided to do it a different way.