Report filter not working properly



  • Luke Nichols


    Interesting find, I don't know why this isn't working. I tried every permutation I could think of with the group filters and I couldn't get it to work. I also tried several different types of SQL reports and couldn't get it.

    The weird thing is that these exact same filters work for a collection, but not for a report. As I see it, you have a few options:

    • Create a collection with those same filters and then run a report with no filters against that collection
    • Try to figure out a SQL report to do this. I tried (and failed) to construct a SQL report with an outer query for application #1 and then a subquery for application #2 since I couldn't figure out how to do it all in one query, but if you're better at SQL than me then you can probably make this work.

    I would open a support case with PDQ as well-- this is probably a bug, given that it works for a collection but not for a report. For reference, my PDQ Inventory version is Enterprise Mode and I was able to reproduce your issue.

    Comment actions Permalink
  • Wayne Osteen

    Thanks for the second set of eyes Luke! I created a collection and it did indeed work.

    I'm opening a ticket right now with support. Cheers!

    Comment actions Permalink

Please sign in to leave a comment.