choose another language

Comments

7 comments

  • Luke Nichols

    Vito,

    Why did you export the package to XML, modify the XML, and then import it?

    I recommend that you duplicate the Mozilla Firefox package then modify the package within PDQ Deploy.

    I think my method is less likely to have errors than yours, although yours is certainly possible if done properly.

    1
    Comment actions Permalink
  • Vito Pacillo

    Hi Luke,

    Thank you for your answer.
    I started using your method but when I duplicate the package eg. "Mozilla Firefox (64-bit) 70.0.1" the new package "Mozilla Firefox (64-bit) 70.0.1 (2)" is created but even on this I can't change anything, it's all disabled, I have to do something other on this clone to be able to edit it?
    Thanks for the reply.

    1
    Comment actions Permalink
  • Luke Nichols

    Vito,

    I think I understand now. Your Mozilla Firefox (64-bit) 70.0.1 package is an auto-download from the package library. It seems that you cannot modify auto-downloads.

    You should delete your Mozilla Firefox package, then go into Package Library > Categories > Internet Browsers. Once you are there, right-click "Mozilla Firefox (64-bit)" and click Download Selected > As Standard Package. You should be able to modify this new package. The standard package has an icon of an open orange box. The auto download package has an icon of the same box, but smaller with a blue arrow around it.

    Here is a picture showing the difference:

    2
    Comment actions Permalink
  • Colby Bouma

    You don't need to delete the Auto Download package, you can convert it to a Standard package:

    2
    Comment actions Permalink
  • Vito Pacillo

    Thank you so much guys!

    the very last thing ... if I didn't want the package to disable automatic updates in the end, in this case of firefox, where do I find this section in the steps of the package itself?

    1
    Comment actions Permalink
  • Luke Nichols

    Thanks Colby, I didn't know that you could convert an Auto Download package to Standard like that.

    Vito,

    It looks like you can just modify the "DisableAppUpdate" line in the policies.json file. Remote "true" and put in "false". I've never done this before, but it seems like it would work to me.

    1
    Comment actions Permalink
  • Vito Pacillo

    many thanks luke !!

    I copied the "policies.json" file and modified it like this:

    {
    "policies": {
    "DisableAppUpdate": false,
    "DontCheckDefaultBrowser": true,
    "DisableTelemetry": true
    }
    }

    and I confirm you that the the autoupdate does not remain disabled !

    many thanks all guys !!

    1
    Comment actions Permalink

Please sign in to leave a comment.