Weekly deployment does not deply

Comments

5 comments

  • Gary White

    While I don't know for sure what the issue is on your side, I can tell you about three ways in which I've had similar issues on my side.

    In one case the package had been moved and the schedule couldn't run because even it showed a package attached, the package was no longer where it expected it to be.

    The second time we had an issue like this was because the dynamic collection it was to run against didn't have any computers present to run against so the schedule just reset to the next run time.

    The last example is that, in the schedule options, I had selected to 'stop deployments to targets once they succeed' and, although there were computers present in the target collection, there we no new computers present on which the package hadn't already run.

    Examples two and three and not actually problems in that they behaved as designed. They just didn't run as I was expecting.

     

    2
    Comment actions Permalink
  • George Eberle

    That is all good info Gary, thank you I am going to check it some more. I do know I can manually run it by choosing the "Start Schedule" over on the far right where it is underlined in blue. It runs that way. So perhaps I can rule out the first option you mention? 

    For the second time, you mention dynamic collection. For me, I running a power shell script off my computer to do it, so I have my computer name listed in the target tab.  The power shell script kicks off a back somewhere else, doing a login and then executing the script. 

    Third example is a bit mind boggling. It is as if the logic implied doesn't mean the same thing as what we would expect?  I am considering unchecking that box and see what outcome I get.

    1
    Comment actions Permalink
  • Gary White

    George, if it runs correctly when you run it manually, I'm thinking that the third example might be your bugaboo. If it ran successfully against your computer once and the package hasn't changed since it last ran, it probably won't run again unless you uncheck that box.Of course, as my wife reminds me of regularly, I have been wrong before..

     

    2
    Comment actions Permalink
  • Colby Bouma

    "Stop deploying to targets once they succeed" means any target that has Successful checked on the Target History tab will not be included in any future deployments. Auto Downloads clear out the Target History tab when they download a new version. For custom packages, you have to clear this out yourself by selecting all targets and hitting Delete.

    2
    Comment actions Permalink
  • Mark Price

    The "Stop Deploying....." was what was hanging me up. Weekly reboot to some desktop PC's in the infrastructure. 

    1
    Comment actions Permalink

Please sign in to leave a comment.