Can't Uninstall Office 2016 with PDQ Deploy

I am trying to uninstall Office 2016 from our computers using Deploy but it fails every time. One deployment ran overnight for 9 hours.
I created the package from Inventory by right clicking on Microsoft Office Standard 2016 in the application list for the computer and created the package in Deploy.
"C:\Program Files (x86)\Common Files\Microsoft Shared\OFFICE16\Office Setup Controller\setup.exe" /uninstall STANDARD /dll OSETUP.DLL

Then I added the follow switches:

I can't find a good set of switches for the command line to know for sure if it is even one of these. I thought it would be on Microsoft's website but I can't find it.

None of these work. It runs until it times out and does not provide an error code or reason as to why it failed. I have been searching online and on this forum for any help and cannot find anything that helps. Has anyone successfully uninstalled Office 2016 from a computer with PDQ Deploy silently?



Date Votes
  • We have an Uninstall Microsoft Office 2016 package in the Package Library. Have you tried that?

  • Well, somehow I completely overlooked the office packages. Not sure how or why I missed them. Running it now.

  • Hi, I am having the same issue with uninstalling Office 2016.

    I have tried both Uninstall MS office v 3.1 and Uninstall MS office 2016 v 3.0

    Both package report back as successful but when we look in C:\Program Files x86\Microsoft Office\ all the office files and folders are still there. Also lists it in add/remove programs.

    Is there anything else we can try. we have over 700 computers to uninstall office from.

    Appreciate any support on this.


Please sign in to leave a comment.

Didn't find what you were looking for?

New post