Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

Did something change in how deploy writes to the DB?

As a kind of DB performance test after updating, I usually select a range or all past deployments and hit delete to see how long it takes to chug through removing them. Typically this takes a moment or two.

After updating from 18.0 - 18.1 then 18.4 today deleting more than a few hundred items locks up the service for about a minute per 1000 deleted. I ran database optimization and tried again with the same results.

Our PDQ VM is on a VM with 6 cores 16 gigs and resides on a PCIE SSD so I thought it strange.

This is by no means a complaint. The software works great in every normal aspect. We are just stress testing and wondered if something had changed.



1 comment
Date Votes
  • Thank you for reporting this! We'll look into it.