Important Notice: On February 29th, this community will be put into read-only mode. All existing posts will remain but customers will be unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

Slow Start and slow UI

Both Deploy & Inventory versions 17,18 & 19 have a slow UI and require quite time to start. We have a very small set of computers. Running on a Windows 2012 R2 server on top of Xeon E3-1220 with 16GB RAM

Why is that?

4

Comments

8 comments
Date Votes
  • We are experiencing the same thing running it on a Windows Server 2016 running a Xeon Gold 6134 3.2 ghz with 16 gb ram. 

    1
  • There are a few things that can help improve performance.

    1. Install Deploy and Inventory on an SSD, if you haven't already.
    2. Configure automatic cleanup in Options --> Preferences.
      Deploy:
          Deployments --> Cleanup. If you do a lot of deployments, set this to a lower number.
          Repository --> See Unused Files. I recommend checking this periodically.
      Inventory:
          PDQ Deploy --> Cleanup deployments older than. I recommend using the same value as Deployment cleanup.
          Scanning --> Auto Cleanup.

    If that doesn't help, please open a ticket with support@pdq.com

    1
  • Hello Colby, but why the UI is slow, there's nothing to do with the SSD or a fast disk...

    Also, earlier versions did not have this poor performance. Did you change the development framework of your apps?? 

    -1
  • I agree, we run ours on a VM (6.7) and I use the defaults. Inventory hangs more often than Deploy but both UIs are slow as molasses. 

    1
  • We haven't changed any frameworks recently. Our products can slow down over time as more data accumulates. We are working on some performance improvements deep in the code, but I don't know when they'll be ready.

    1
  • Same issue here, i think we will leave PDQdeploy : the UI is just unusable with many deployment running ... that's real fact.

    No renewal, if no quick fix. (this issue was mentioned 2 years ago : no excuse )

    i want to call PDQDeploy : the "NOT RESPONDING APP" !

     

    (and i don't no why there is a repository cleanup ... , )

    0
  • Since update to v19.3 PDQDeploy and PDQInventory (again) take loooong time to start.

    Please optimize start behavior of the Applications, would be very much apprechiated!

    Cheers,

    Michael

    0
  • I've been experiencing slow launch and UI lag consistently, even after our initial installation, before setting up ANYTHING.

    Often PDQ Inventory will become unresponsive in Task Manager for several minutes after launch and invoking PDQ Deploy from PDQ inventory can take 2-3 minutes.

    We are running things on a Windows Server 2019 VM, with 8 cores and 16 GB of RAM.

    1

Please sign in to leave a comment.

Didn't find what you were looking for?

New post