Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

Can't upgrade to .NET 4.8 for Server

We have 2 servers that cannot goto .NET 4.8 because of software on them that do not support it.

Does this mean we can't upgrade PDQ till those are out of production or we have remove those 2 servers and manually deal with them?

What exactly happens or will I miss if machines don't have .net 4.8 if PDQ is upgraded to the latest?





Date Votes
  • .NET 4.8 is required on the machine running PDQ Deploy and Inventory and later, and is required on any targets you would like to scan with that version. Deployments do not currently require it.

    I am curious, what is the application that is incompatible with .NET 4.8?

  • One is Exchange 2010, that's on it's way out as we speak. The other is called iMIS. It's a server database & application that handles all our members. I put .net 4.8 on the database because that didn't matter but the application server is not supported with it. Supposedly iMIS only supports 4.6.2 & 3.5.

    I think if it supports 4.6.2 then it should support 4.8, but I'll need to test all that first. Currently support is telling me if it's not listed they won't support.

  • Same surprise here. ( didn't read the changelog good enough haha)

    Is it possible to downgrade PDQ inventory to previous version to buy some extra time to install .net 4.8 on all the targets ?
    How can i downgrade ? Just install the previous installer ?


  • I think you can just downgrade it. At worst, uninstall and then install older one. We put our upgrade on hold for now to weigh the option of whether it's worth upgrading and excommunicating the 2 servers.

  • Downgrading requires that you uninstall the current version before reinstalling the previous version. Your database will not be affected by this.

  • Good news! It looks like the current Beta dropped the requirement down to 4.6.1!

  • Rex, Thanks. This would be helpful. However I'm already planning to have all servers to at least 4.8 by summer. Crossing my fingers.