Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

Batch file not running with new Autodesk deployment

Trying to use the new Autodesk deployment too to deploy 3DS MAX 2021 to some target computer. I first tried copying the GUI version of the install command from within the batch file and simply use it as a command step, but that did not work. It would just time out with no visible results. Next, I tried including the actual batch file in the command step and used a CALL command to call the default batch file that autodesk provides. If I run the command from the network share on the local computer, or pull the entire directory down to the local computer and this, it works fine. For whatever reason it is not working when I try to deploy it with PDQ. any ideas?



Date Votes
  • Could you paste here what command you're trying to run for the installer? Or a screenshot of your PDQ step?

  • "\\[server]\shares\Software\_PDQ Deployments\Autodesk\3DS Max 2021\2021_2\image\Installer.exe" -i deploy -q --offline_mode -o "\\[server]\shares\Software\_PDQ Deployments\Autodesk\3DS Max 2021\2021_2\image\Deployment.xml" --manifest "\\[server]\shares\Software\_PDQ Deployments\Autodesk\3DS Max 2021\2021_2\image\{[redacted]}\setup.xml"

  • I'm also experiencing this with Autodesk Revit 2021 with their new web deployment download... I haven't messed around with it enough yet but so far just running the command with the -q doesn't work via PDQ it launches the installer.exe but never actually does anything, nothing gets created in %temp% etc...

  • So far the only way I found this to work was "including the entire directory" when specifying the batch file. Kind of defeats the purpose, but still works!

  • Hmm, thanks for that tip, I'll work on it more tomorrow but that implies it may be an issue with the working/current directory, or some reference back to the directory for reading or writing something... Will update here if I figure it out but that helps at least get it deployed which is easier than logging into hundreds of systems to run it that way.  Thanks :)

  • did you guys ever find a solution to this? I am dealing with the same problem 

  • I'm also dealing with this issue with their new online Custom Deployment.  It works if you run the batch file locally, but not if you're running it through PDQ Deploy.  I still haven't figured it out, but I've been working on it for the past week.

    Anyone have a fix for this yet?

  • Hi Joseph, 

    I got mine working by copy and pasting the script it creates into a command step, it didn't seem to like it if you use the insert batch button. Set your user to Deploy User (interactive) and it seems to be working for me. I did have to use a GPO to ensure file sharing was enabled on PCs to accept the package as well. 


  • I wonder if there's any more information about this. I'm looking to deploy Revit to 40 workstations soon. I have a .bat file that was created with their online deployment.

    Any help would be wildly appreciated, I'll help little old ladies cross streets for a month!!!

    Here's the contents:


    chcp 65001


    rem ========== Install the deployment with basic UI ==========

    "\\myVM-vs-005\myVM_software\Revit Install\2022 Revit Deployment\image\Installer.exe" -i deploy --offline_mode --ui_mode basic -o "\\myVM-vs-005\myVM_software\Revit Install\2022 Revit Deployment\image\Collection.xml" --installer_version ""


    rem ========== Install the deployment silently ==========

    rem "\\myVM-vs-005\myVM_software\Revit Install\2022 Revit Deployment\image\Installer.exe" -i deploy --offline_mode -q -o "\\myVM-vs-005\myVM_software\Revit Install\2022 Revit Deployment\image\Collection.xml" --installer_version ""


    rem ========== Uninstall the individual product ==========


    rem ========== Uninstall Autodesk Revit 2022

    rem "\\myVM-vs-005\myVM_software\Revit Install\2022 Revit Deployment\image\Installer.exe" -i uninstall -q --manifest "\\myVM-vs-005\myVM_software\Revit Install\2022 Revit Deployment\image\RVT_2022_en-US\setup.xml" --extension_manifest "\\myVM-vs-005\myVM_software\Revit Install\2022 Revit Deployment\image\RVT_2022_en-US\setup_ext.xml"


    rem "\\myVM-vs-005\myVM_software\Revit Install\2022 Revit Deployment\image\Installer.exe" -i uninstall -q --manifest "\\myVM-vs-005\myVM_software\Revit Install\2022 Revit Deployment\image\ODIS\setup.xml"

  • Hi Rick,

    I made my own batch file based on the one provided to get my software installed.  It doesn't like running the installer off a network share and prefers to be run locally it seems.


    echo Copy folder to local
    xcopy "%serverPath%\Maya 2020.4" "C:\Autodesk\Maya 2020.4\" /Y /S /Q

    echo Run Maya 2020.4 Installer
    chcp 65001
    call "%localPath%\Maya 2020.4\image\Installer.exe" -i deploy --offline_mode -q -o "%localPath%\Maya 2020.4\image\Collection.xml" --installer_version ""

    echo Delete folder
    RD /S /Q "C:\Autodesk\Maya 2020.4"

  • Thanks Joseph. Did you try to deploy Maya from the server with PDQ set to pull? I  didn't have to copy files to the local machine.

    I spoke to my autodesk dealer tech person, and followed his advice.

    I opened the batch file in Notepad++, there was only one line that was NOT remarked out. I copied that line into a copy of my 2020 PDQ deployment, pasted it into a command step, seems to have succeeded just fine. I'll test it today, if I find any problems I'll stop back and let everyone know.

    FYI, here's my notes from the original 2020 deployment:

    MAKE SURE YOU CHANGE TO A PULL (properties--options)

    Grab the path from the deployment shortcut.

    The only trick is that I added the slash W parameter (note: I did NOT do this for 2022)

    Error codes: 0,1641,3010