Siemens UGS NX12

Hi there,

i try for several days to get the NX12 silent installation running. If i run the following command in cmd local on the computer it works:

msiexec.exe /qn /i “\\Server\Install\CAD\UGS_NX_12.msi” ADDLOCAL=”ALL” INSTALLDIR=”C:\UGS\NX12” LICENSESERVER=28000@Server

if i put it in a command step it won't install. In MS Eventlog i get the error: Product: Siemens NX 12.0.2 -- Error 1606. Could not access network location "C:\UGS\NX12".

if i run the install step with this msi the installation runs in an timeout.

Has someone a hint for me, what i am doing wrong?



Date Votes
  • Frederic,

    I have a couple of questions about your setup:

    • Is there any reason you're not just doing a standard install step with the MSI file being in your PDQ Deploy repository? Why are you referencing it via UNC path in a command step?
    • Make sure your deploy user has permissions to that UNC path
    • Your install is probably failing because the folder you are deploying to does not exist and it is not smart enough to create the folder. I highly recommend that you use the default install location unless you have a good reason to install it elsewhere. Using the default location will make integration with other software easier and will make it easier for someone else to manage this environment after you.
    • You could create a command (PowerShell) step right before this step to ensure the folder is created like so:

      $Path = "C:\UGS\"
      $Folder = "NX12"
      If (!(Test-Path $Path$Folder)) { New-Item -Path $Path -Name $Folder -ItemType "directory" }
  • Hello Luke, thanks for your fast answer


    if i run the install step with this msi the installation runs in an timeout. (i only added to the Custom Command Line /Licenseserver=...

    My deploy user has permissions in the unc path (everybody read, deployuser read/write)

    is there a way to see why there is a timeout while installing via the install step?

    Btw. the Folder C:\UGS\NX12 already exists with the right permissions

  • Frederic,

    The best way in my experience to find why an installation is timing out or hanging is to check the installer log file. I am not sure where the default location is because I manually change mine. Here is a picture of the install step from my SIemens NX package:

    So if you were using my settings you could look at C:\Temp\NX1934_output.log in order to see why it timed out. You probably need to supply an additional argument or your arguments are malformed which is why it's timing out.

  • Hi Luke,

    sry for the late answer (short-time work). I tested it exactly like you and it works (without the commands for installdir and license server) but what i forgot was the "include entire directory". thank you very much for your help :)


Please sign in to leave a comment.

Didn't find what you were looking for?

New post