Canon CapturePerfect Silent Install

Comments

7 comments

  • Dan Martin

    We have use PDQ to install capture perfect 3.1.41. Since it's an installshield installer you first need to create a setup.iss response file and put that in the install directory. And then just run the installer with a /s parameter.

     

    I did find that if you don't need the sharepoint plugin delete that plugin folder in the installer folder before you create your setup.iss file.   

     

    http://www.silentinstall.org/InstallShield 

    1
    Comment actions Permalink
  • Evan Gruzlewski

    Please make sure that you have the box that says "Include Entire Directory" checked in the package setup. This option is required any time that there is more than just a singular setup file, such as setup.exe. For your case this is true, where there are data.cab files in the same directory that are most definitely required.

    0
    Comment actions Permalink
  • Chris Klingler

    Thanks for the response, Evan. There are data.cab files in that directory! Unfortunately, checking that box didn't do the trick, though. It still isn't working.

    0
    Comment actions Permalink
  • Evan Gruzlewski

    Chris, what version are you trying to install and can you link to where you got it?

    0
    Comment actions Permalink
  • Chris Klingler

    Thanks for responding again,Evan. I am trying to install CapturePerfect v3.1.

    I got the software from a disk that was included with the scanner. I just checked online because I thought that Canon had a download was available to anyone, but it looks like they don't have the full version of the software available for download. They just have upgrades, unfortunately. I would be happy to send the install file to you through dropbox, box, google drive, or onedrive if you'd like, but I understand that you may not find that very secure. 

    0
    Comment actions Permalink
  • Chris Klingler

    Your solution worked! 

    Deleting that plugin folder and running the install with an /s parameter and linking to the .iss response file did the trick.

    Amazing. This will save me so much time! Thanks, Dan! I really appreciate the help.

    0
    Comment actions Permalink
  • Dave Underwood

    Thank you for your help as well with this!  I know a couple years ago I failed at trying to get a package to work.  Today, 10 min later - Success!

    One more thing to mention for those that have not created a setup.iss file before, here's a quick tip:

    To create the setup.iss file:

    in cmd prompt cd to your setup.exe file then type:

    setup.exe -r

    After you complete the setup, the "setup.iss" file will be located in your C:\Windows directory.

    Copy that file to where your setup.exe is.

    Then with PDQ Deploy - Create the package, navigating to the setup.exe

    Make sure to check the box "Include entire directory"

    Then make sure to add the "-s" parameter to setup.exe

    setup.exe -s

    0
    Comment actions Permalink

Please sign in to leave a comment.