Canon EOS Utility Silent Install

Hello Everyone,

I am trying to get a silent install working with Canon's EOS Utility, but when I run the installer it brings up a box asking what language to use. 

I have tried silent switches from the command line but none of them seem to have any effect. It seems to be a self extracting file which then launches a file called UniversalInstaller.exe

Does anyone have a working install method for this software? I'm trying to install v3.13.10 from the Canon site.



Date Votes
  • I have no experience with that program, but some installers use /L=1033 to set the language to English.

  • Try this.

    .\Setup.exe /exenoui /exelang 1033 /exelog c:\temp\canon\canon.log /exenoupdates /noprereqs /qn /norestart



  • I'm in the same situation as the op, Codec303, except for Canon's XF utility. ...self-extracting installer which launches UniversalInstaller.exe. I tried using 7-Zip to extract/inflate the installer (xuw311.exe) itself, thinking that unattended switches may work with a packaged installer executable, but no such luck. The output was a .rsrc folder, and files like .data, .gfids, .rdata, etc. Jeff Peter I tried all of the options you suggested with xuw311.exe, with no luck, and also tried variations of the options. I also tried the usual suspects /silent, /verysilent, /s, /s /v/qn, /qn, /q. I also tried many of the options with dashes (e.g. -q) instead of slashes. None of this helped. Looking at the properties for xuw311.exe, Details tab, File description is One File Installer and Original filename is OFICore.exe. A brief web search turned up little info about One File Installer. It doesn't appear to be a widely-used / well-documented installer. Maybe it's a proprietary / Canon-only installer...


Please sign in to leave a comment.

Didn't find what you were looking for?

New post