Command prompt works, but not in PDQ Deploy

I've had this come up a couple of times. I'll have a job that will run fine in the Command Prompt but fails with PDQ Deploy, usually with an error code 1.

The latest one is this one to remove a homegrown app:

“c:\Program Files (x86)\Common Files\Microsoft Shared\VSTO\10.0\VSTOInstaller.exe” /Uninstall file:// /Quiet

I have tried running it as the logged on user but that doesn't help either.

Any ideas why this is occurring?



Date Votes
  • Is there anything in the Output Log?

  • This:

    At C:\WINDOWS\AdminArsenal\PDQDeployRunner\service-1\exec\user.ps1:1 char:85
    + ... \Common Files\Microsoft Shared\VSTO\10.0\VSTOInstaller.exe" /Uninstal ...
    + ~
    You must provide a value expression following the '/' operator.
    At C:\WINDOWS\AdminArsenal\PDQDeployRunner\service-1\exec\user.ps1:1 char:85
    + ... iles\Microsoft Shared\VSTO\10.0\VSTOInstaller.exe" /Uninstall file:// ...
    + ~~~~~~~~~
    Unexpected token 'Uninstall' in expression or statement.
    + CategoryInfo : ParserError: (:) [], ParentContainsErrorRecordException
    + FullyQualifiedErrorId : ExpectedValueExpression


    It does work in the command prompt.

  • It looks like you're running that in a PowerShell step, but it doesn't look like PowerShell code. Have you tried the Command step?

  • Sorry, that was an older attempt when I tried it in PS. Here is the one from Command:

    The filename, directory name, or volume label syntax is incorrect.

  • My assumption is that it's referring to the file:// part, probably the PDQ%20Deploy section. Would you be comfortable exporting your package to XML and sharing it here? If not, contact They can dig a lot deeper than I can from here.

  • I'll reach out to support. Thanks for the help.


Please sign in to leave a comment.

Didn't find what you were looking for?

New post