PDQ Deploy - AutoCad 2022

Comments

15 comments

  • Margus Kamenjuk

    Never done it, but as usual rule for me, try first install directly in pc command line with same method and if it works it will work also from pdq. cmd step in pdq basically uses only additional psexcec and also there are log files in windir/adminarsenal

    maybe it fails because of prerequisites and components? 

    https://silentinstallhq.com/autodesk-autocad-2021-silent-install-how-to-guide/

    https://docs.liquit.com/docs/lsc-kb2021032401

    0
    Comment actions Permalink
  • Adam Gould

    Thanks Maki, I have tested it in command line and it works and it will install fine on the server that hosts PDQ now but for some reason I am getting a time out after 3 hours on PCs on the network. 

    0
    Comment actions Permalink
  • Kerry Hoskin

    have you had any luck with this?  I'm about to try and get autocad 2022, inventor 2022 and vault 2022 installed.  Lucky old me!

    0
    Comment actions Permalink
  • Ric Berryman

    Having the same issue.

    0
    Comment actions Permalink
  • Chris Lambert

    There used to be a network deployment method for Autodesk products.  It has been some time, but I recall doing a custom installer with Autodesk's tools. With a quick search I found this link:  https://knowledge.autodesk.com/support/autocad/learn-explore/caas/sfdcarticles/sfdcarticles/Deploying-Autodesk-Software-to-Many-Computers.html

     

    0
    Comment actions Permalink
  • Pete Chenard

    I'm just getting ready to roll out the Autodesk AEC collection of software.  So far I have done one test deployment of Civil 3D to one workstation using PDQ Deploy and it was successful after about 29 min.  I just created a PDQ Deploy package with a command step that uses the install syntax form the "Install the deployment silently" line in the batch file that the new online Autodesk deployment tool creates.  It looks like this:

    "\\<servername>\repository\Deployments\Autodesk\C3D-2022\image\Installer.exe" -i deploy --offline_mode -q -o "\\<servername>\repository\Deployments\Autodesk\C3D-2022\image\Collection.xml" --installer_version "1.21.0.24"

    I did not change anything in the command syntax (server name is edited for display here).  I just cut it from the batch file and pasted it into my PDQ Deployment command.

    0
    Comment actions Permalink
  • Pete Chenard

    Just an update.  So far I have been able to deploy the 2022 versions of Civil 3D, Plant 3D, Vehicle Tracking, ReCap Pro, Raster Design, InfraWorks, and Navisworks Manage, just as I described in my previous post.  I have only deployed them to one workstation, but they all deployed from PDQ successfully and all function normally.

    0
    Comment actions Permalink
  • Matt Bennum

    I'm doing the same thing (just putting the command line step into a package) and it just times out after a couple hours. 

    Pete, are you using a service account with admin privileges, or does the end user account on the workstation have admin rights? 

    0
    Comment actions Permalink
  • Pete Chenard

    I use a domain admin account to do all of my PDQ Deploy installations.

    0
    Comment actions Permalink
  • Rudy Mens

    It seems that the ProcessManager.exe in the folder \image\Setup is blocking the installation. It throws an Open File - Security Warning even though you run the installation with admin privileges.

    I started the installation with the basic UI: 

    "\\contoso.local\repository\Autodesk\2022_Suite\image\Installer.exe" -i deploy --offline_mode --ui_mode basic -o "\\contoso.local\repository\Autodesk\2022_Suite\image\Collection.xml" --installer_version "1.21.0.24"

    Which should only show the progress, but it gave me the Open File security warning only for the ProcessManager.exe.

    Now figuring the correct way to whitelist file domain-wide, testing Software Restriction policy to set the file to unrestricted.

     

    0
    Comment actions Permalink
  • Michael Potoka

    I also am having issues with Autocad - 

    "\\<<servername>>\autodesk-2022\Autocad\image\Installer.exe" -i deploy --offline_mode --ui_mode basic -o "\\<<servername>>\AutoDesk\Deployments\autodesk-2022\Autocad\image\Collection.xml" --installer_version "1.21.0.25"

    that line when run locally on a machine from command line will work as expected with the basic gui.  Same command via PDQ command step will not work - Error 17

    "\\<<servername>>\AutoDesk\Deployments\autodesk-2022\Autocad\image\Installer.exe" -i deploy --offline_mode -q -o "\\<<servername>>\AutoDesk\Deployments\autodesk-2022\Autocad\image\Collection.xml" --installer_version "1.21.0.25"

    even run locally, the silent installation will not fail.  Struggling to find the cause in Event Viewer

    My revit deployment I made right after the Autocad deployment works via PDQ.

    0
    Comment actions Permalink
  • Paul Johnson

    I am having the Open File - Security Warning mentioned by Rudy as well. Did anyone experience this and solve it? What was your solution. 

    0
    Comment actions Permalink
  • Pete Chenard

    I have now installed several of our Autodesk products using PDQ Deploy as I described above onto several workstations with zero issues.

    0
    Comment actions Permalink
  • Dylan Laborde

     Paul Johnson Rudy Mens Matt Bennum Adam Gould 

    I was getting stuck with the ProcessManager.exe prompt as well. I was using the DFS path in my script, but I was able to get around this by using the FQDN of the path to the installer instead. 

    I hope this helps y'all because I was scratching my head for hours at this one.

    0
    Comment actions Permalink
  • Pete Chenard

    Hmmm...I see I changed my example to <servername> but I actually use the DFS path <mydomain.local> and it works fine.

    0
    Comment actions Permalink

Please sign in to leave a comment.