Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

PDQ Deploy - AutoCad 2022


I'm trying to deploy AutoCad 2022 using the new package creation method and the batch file that is produced from that. I've tried loading the batch file as a command step but the install just runs forever and times out. I've tried only putting in the silent install line from the batch file and it fails immediately. Has anyone used this method to deploy yet ? 





Date Votes
  • Never done it, but as usual rule for me, try first install directly in pc command line with same method and if it works it will work also from pdq. cmd step in pdq basically uses only additional psexcec and also there are log files in windir/adminarsenal

    maybe it fails because of prerequisites and components?

  • Thanks Maki, I have tested it in command line and it works and it will install fine on the server that hosts PDQ now but for some reason I am getting a time out after 3 hours on PCs on the network. 

  • have you had any luck with this?  I'm about to try and get autocad 2022, inventor 2022 and vault 2022 installed.  Lucky old me!

  • Having the same issue.

  • There used to be a network deployment method for Autodesk products.  It has been some time, but I recall doing a custom installer with Autodesk's tools. With a quick search I found this link:


  • I'm just getting ready to roll out the Autodesk AEC collection of software.  So far I have done one test deployment of Civil 3D to one workstation using PDQ Deploy and it was successful after about 29 min.  I just created a PDQ Deploy package with a command step that uses the install syntax form the "Install the deployment silently" line in the batch file that the new online Autodesk deployment tool creates.  It looks like this:

    "\\<servername>\repository\Deployments\Autodesk\C3D-2022\image\Installer.exe" -i deploy --offline_mode -q -o "\\<servername>\repository\Deployments\Autodesk\C3D-2022\image\Collection.xml" --installer_version ""

    I did not change anything in the command syntax (server name is edited for display here).  I just cut it from the batch file and pasted it into my PDQ Deployment command.

  • Just an update.  So far I have been able to deploy the 2022 versions of Civil 3D, Plant 3D, Vehicle Tracking, ReCap Pro, Raster Design, InfraWorks, and Navisworks Manage, just as I described in my previous post.  I have only deployed them to one workstation, but they all deployed from PDQ successfully and all function normally.

  • I'm doing the same thing (just putting the command line step into a package) and it just times out after a couple hours. 

    Pete, are you using a service account with admin privileges, or does the end user account on the workstation have admin rights? 

  • I use a domain admin account to do all of my PDQ Deploy installations.

  • It seems that the ProcessManager.exe in the folder \image\Setup is blocking the installation. It throws an Open File - Security Warning even though you run the installation with admin privileges.

    I started the installation with the basic UI: 

    "\\contoso.local\repository\Autodesk\2022_Suite\image\Installer.exe" -i deploy --offline_mode --ui_mode basic -o "\\contoso.local\repository\Autodesk\2022_Suite\image\Collection.xml" --installer_version ""

    Which should only show the progress, but it gave me the Open File security warning only for the ProcessManager.exe.

    Now figuring the correct way to whitelist file domain-wide, testing Software Restriction policy to set the file to unrestricted.


  • I also am having issues with Autocad - 

    "\\<<servername>>\autodesk-2022\Autocad\image\Installer.exe" -i deploy --offline_mode --ui_mode basic -o "\\<<servername>>\AutoDesk\Deployments\autodesk-2022\Autocad\image\Collection.xml" --installer_version ""

    that line when run locally on a machine from command line will work as expected with the basic gui.  Same command via PDQ command step will not work - Error 17

    "\\<<servername>>\AutoDesk\Deployments\autodesk-2022\Autocad\image\Installer.exe" -i deploy --offline_mode -q -o "\\<<servername>>\AutoDesk\Deployments\autodesk-2022\Autocad\image\Collection.xml" --installer_version ""

    even run locally, the silent installation will not fail.  Struggling to find the cause in Event Viewer

    My revit deployment I made right after the Autocad deployment works via PDQ.

  • I am having the Open File - Security Warning mentioned by Rudy as well. Did anyone experience this and solve it? What was your solution. 

  • I have now installed several of our Autodesk products using PDQ Deploy as I described above onto several workstations with zero issues.

  •  Paul Johnson Rudy Mens Matt Bennum Adam Gould 

    I was getting stuck with the ProcessManager.exe prompt as well. I was using the DFS path in my script, but I was able to get around this by using the FQDN of the path to the installer instead. 

    I hope this helps y'all because I was scratching my head for hours at this one.

  • Hmmm...I see I changed my example to <servername> but I actually use the DFS path <mydomain.local> and it works fine.

  • I'm using the FQDN path, so in PDQ Deploy I have a package with a command line script that looks like this

    "\\\pdq\software\autodesk\Infraworks2022\image\Installer.exe" -i deploy --offline_mode -q -o "\\\pdq\software\autodesk\Infraworks2022\image\Collection.xml" --installer_version ""

    I've tried every combination of everything I can think of but I am still getting the "this file is outside your network" security warning on ProcessManager.exe

  • Just in case any of you missed this...

    🔴Autodesk Deployment 2021 - YouTube

    You are supposed to be able to submit questions ahead of time, but I don't know how you do that.

  • So I think I tracked down the reason I'm having trouble with this, figured I would follow up here in case it helps anyone else. 

    In our case the culprit was (is) DFS. We have PDQ Central server set up along with DFS so we can push deployments from one PDQ server to all of our remote offices. This usually works, except DFS doesn't always pick the server local to the machine getting the deployment, it picks the one that responds first. In the case of these Autodesk deployments, the initial installer at some point calls the "ProcessManager.exe" which requires admin rights, and was causing windows to freak out and flag it as "outside the network" since it was sometimes trying to open that file from an office across our WAN and not the server down the hall.

    If I "bypass" DFS by pointing the PDQ deployment directly to the local server share, it works fine. IMO this isn't a viable workaround because I'm not going to create a separate deployment for each office we have and for each Autodesk software package.

    We don't have a fix yet but I have a feeling it's going to involve firewall rules to stop DFS from acting this way. The upside is it'll reduce network traffic on other installs, as this isn't an Autodesk-only issue, Autodesk just happens to be the only ones with a weird enough install process to make Windows throw up red flags. 

  • Thanks for the update.

    Has anyone else tackled the update installer?

  • For us, the fix ended up pretty simple - we set the PDQ deployment to include entire directory (yes, all 4.7 GB).  With that, I was able to use the modified BAT file included in the Autodesk deployment package to install silently & successfully.  Hope that helps!

  • I was having this same problem with the deployment created by the Autodesk deployment tool for Revit 2022. I tried Dan Carp's suggestion of checking the "include entire directory" box (from an install step) and that worked but including all files in the Revit folder is almost 15GB so I would really like to avoid that if possible as it will really slow down mass deployments. In the past this was not required with the classic deployment builder. Anyone else have other solutions that work? I tried calling the bat file from a command step and also pasting that commend directly in and both of those just hang. We are using DFS shares which someone else mentioned was an issue for them but we really need DFS due to multiple branch offices. To add we've been using DFS without issue for all our past Autodesk deployments.

  • We use DFS namespace as well and prefer to use the command step with Autodesk applications due to the significant size of the install folder. I was able to solve my issue by making sure \\ and * were in the  trusted security zone for the computer.

    I was not sure why this was necessary since all other deployments will deploy as expected including the older Autodesk installer technology. Must be something unique or new in the Autodesk 2022 and newer installer that this is a requirement. 

  • Paul Johnson thanks for the suggestion. I'm assuming you mean you added the DFS path to the trusted sites? Did you do this in the site to zone assignment list in GPO or somewhere else? 

  • Sam Newby, correct, I used a GPO to distribute a script to write the registry entries of the DFS path to the local intranet zone in my environment. 

  • hi Community!

    In my Case the Installation of Revit 2022 with the Deployment Tool from Autodesk ist working fine.

    But PDQ Deploy is running in an endless cycle... It does NOT Finish the Installation, but on the Mashine it is Finished an works fine.

    When i restart the Mashine PDQ shows an "Failed" report in the Deploy lineIn my Deployment Settings i have this Success Codes in use: 0,1641,3010

    is there some oder codes i need to use for Finishing the Installation?


    Best Regards,



  • After quite a few tries, I finally have a working solution. Since my PDQ Deploy account never logs into the PC, the registry isn't populated w/ the needed zones. I use DFS to keep my depo's synced between 3 sites, so using our DFS path is a requirement. I had to create a job for my DEPLOY user account that creates/import reg keys for my local domain. The 2 areas I had to create or modify keys were for Zonemap, and ZoneMapKey under HKEY_CURRENT_USER. See below.


    EX: [HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Windows\CurrentVersion\Internet Settings\ZoneMap\Domains\]

    [HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Windows\CurrentVersion\Internet Settings\ZoneMapKey]


    Before I deploy anything Autodesk 2023, we run this Reg update job. Some of the ZoneMapKeys might be overkill. 

    Hope this helps a fellow PDQ user.


  • for DFS issues and lots of referral targets, you can change dfs to specific site server with cmd step:

    # change DFS to LOCALSERVER2
    dfsutil client property state active \\\repository "\\LOCALSERVER2\repository"

    also add dfsutil to deploy Files (C:\Windows\System32\dfsutil.exe & \en-US\dfsutil.exe.mui)


    or wherever it's accessible remotely


    also if you have billion DC-s and replication issues you can change DC to DC2 in cmd step

    # change to DC2
    nltest /Server:$(Computer:TARGETHOSTNAME) /\DC2
    # check
    psexec \\$(Computer:TARGETHOSTNAME) nltest /