Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

PDQ - Deploy - Uninstallation package - not working

Hi,

I have made a uninstall package from PDQ Inventory. The uninstallation package is made by right click on the application in the application list, and click "Create Uninstallation package in PDQ Deploy".
The Command line in the uninstallation package is:
"C:\ProgramData\bomgar-scc-0x60c1b21c\bomgar-scc.exe" -pinned win32uninstall /no-spinner

When I'm deploying this uninstall package, I keep getting the error:
"The system cannot find the path specified."
I found out that this was caused by PDQ using FQDN of the computer(s) the package was deployed to.
I solved this by making a txt file with only the ip-adresses of the computers, and used this file when I choosed "targets".

Now I managed to run the deployment of the uninstall package without getting errors. But the package just keeps running and running, and never stops.

The deployment of the uninstall package was only deployed to one computer, by using a txt file (with only the one ip-adress of the actual computer).
There is a reason for that, because one of the folders in this path:
"C:\ProgramData\bomgar-scc-0x60c1b21c\bomgar-scc.exe"
is not the same on all of the computers I want to deploy the uninstallation package to. The folder "bomgar-scc-0x60c1b21c" is uniqe for only the one computer I did test the deployment of the uninstallation package to.
I tried using wildcard "*", like this: "C:\ProgramData\bomgar-scc*", but then I get "The system cannot find the path specified.".

So I have two problems:

1. Why isn't the deployment of the uninstallation package working as intended?
2. I need som help using wildcards for the folder "C:\ProgramData\bomgar-scc-..............". Only then I can deploy this uninstallation package to all my computers.

The application I need to uninstall is: Remote Support Jump Client 21.1.2 (Publisher: BeyondTrust)

0

Comments

2 comments
Date Votes
    1. It's probably missing a switch to make the uninstall silent. Inventory pulls the uninstall string from the registry, which is a value the application sets when it's installed. Publishers frequently don't include the silent switch in the uninstall string. You can try adding standard switches like /S, /Q, /quiet, but you may have to reach out to the publisher.
      https://www.pdq.com/blog/install-silent-finding-silent-parameters/
    2. You'll have to use something like PowerShell to find that path first.
    Resolve-Path 'C:\ProgramData\bomgar-scc*'
    0
  • you are missing -silent switch

    0