Deploying Autodesk Custom Installations with PDQ Deploy: Access is denied.

Dear fellow PDQ users,

At my work, I am trying to deploy Autodesk Maya 2022 to our Windows 10 students computers. But I can not get it to work. This is similar for all Autodesk products where I use the .batch file that comes after creating the custom installation in their portal. I am getting the following output log:

C:\WINDOWS\AdminArsenal\PDQDeployRunner\service-1\exec>CALL "Install Autodesk_Maya_2022_X64.bat"

C:\WINDOWS\AdminArsenal\PDQDeployRunner\service-1\exec>chcp 65001
Active code page: 65001

C:\WINDOWS\AdminArsenal\PDQDeployRunner\service-1\exec>rem ========== Install the deployment with basic UI ==========

C:\WINDOWS\AdminArsenal\PDQDeployRunner\service-1\exec>"//$/Applications/Autodesk/Maya_2022/Deployment\image\Installer.exe" -i deploy --offline_mode --ui_mode basic -o "//$/Applications/Autodesk/Maya_2022/Deployment\image\Collection.xml" --installer_version ""
Access is denied.

I know for a fact that it doens't have to do anything with the deploy account (sa_pdq_adm) not having rights. The account does have admin$ rights. So somewhere else something goes wrong.

Anyone knows what is going on here and how I can fix it? Thank you so much.



Date Votes
  • Is a share it's trying to access? And getting access denied. Have you tried adding a step to file copy all necessary files needed to do the install to following directory  C:\Windows\AdminArsenal\autodesk and adding a step like:

    cd C:\Windows\AdminArsenal\autodesk

    call Install Autodesk_Maya_2022_X64.bat

  • Thanks for your reply!


    Correct. is a share that is getting accessed because there are the source files and the batch file. But all my software deployed with PDQ Deploy is on that share. And never it's a problem. Funny thing: when I run that batch file manually, it's installing perfectly. Only with PDQ Deploy I am getting that "Access Denied" error.

    I am going to try your suggestion. Thanks.


Please sign in to leave a comment.

Didn't find what you were looking for?

New post