Program 'PDQInventory.exe' failed to run: This operation requires an interactive window station

Hi there,

I'm running an Azure Runbook via a Hybrid Worker on an On Prem server, running Windows Server 2016 Datacenter.

The Runbook is a Powershell script that should run GetAllComputers from PDQInventory find the Machine a user is logged in as using PDQInventory GetComputer, and then use PDQDeploy Deploy to deploy a package to the user.

I am getting the following issue when running the GetAllComputers command:

"Program 'PDQInventory.exe' failed to run: This operation requires an interactive window station"

When I run in the powershell in a non-elevated window, I notice a new commandline window flashes up and displays the results before disappearing. When I run the powershell in an elevated window, it returns the results directly to the powershell window, instead of opening a new window.

Please can somebody help?





Date Votes
  • Theo,

    If you haven't already I recommend that you submit a support ticket to PDQ here:

    These are the community forums and while employees do post here sometimes you will definitely get a more prompt response via official support channels.

  • I don't know if its the same issue. But I've had problems running PowerShell scripts directly from PDQDeploy, meaning putting the body of the script into deploy and not calling a script file. If you aren't, try making the script a .ps1 file and calling the file instead of running the script directly. Otherwise I'd agree, contact pdq support.


Please sign in to leave a comment.

Didn't find what you were looking for?

New post