Important Notice: On February 29th, this community will be put into read-only mode. All existing posts will remain but customers will be unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

Deploy Autodesk Products with Integrated Silent Installer

On a yearly basis, we install the Autodesk suite of products to our workstations.  The suite includes a deployment tool that can be used to create a silent deployment for individual workstations.  The deployment, in this case of the 2014 Building Design Premium suite, for an individual workstation is kicked off by a shortcut with the following target:

"\\Path\Img\Setup.exe" /qb /I \\Path\Img\DeployParameters.ini /language en-us

I would have thought that I could kick this process off via PDQ Deploy by pointing Install File to the setup.exe and including the balance of the link in the Parameters field.  When I try to initiate a deployment, however, PDQ Deploy connects but then runs until the process times out.

Further, when starting the deployment manually by double clicking the link, a dialog box appears with installation progress (no need for user input, however).  When starting with PDQ Deploy, nothing shows up which makes me believe nothing is being executed.

Could you suggest what I might be missing and how I could kick this off successfully?  Thanks in advance!

7

Comments

73 comments
Date Votes
  • Based on some other things I've read, I can add a bit more info...

    If I try to kick off the installer by typing the link's target ("\\Path\Img\Setup.exe" /qb /I \\Path\Img\DeployParameters.ini /language en-us) into a command prompt, nothing happens.  But if I type the path to the link itself ("\\Path\DeployLink.lnk"), the process kicks off successfully.

    Firstly, what could be special about the LNK file?  Does it have to do with the "Start in" field ("\\Path\Img")?

    Secondly, is there simply a way for PDQ Deploy to call the LNK file and then let the LNK do the work?

    0
  • Any luck with this?

    Im currently looking in too the same thing. But i'm looking in to deployment in general, if PDQ is a good tool for Autodesk design suites.

    Have you tried to build your own installer sequence from scratch ditching the lnk-file?

    Take a look at: http://docs.autodesk.com/INSTALL_LICENSE/2014/ENU/Autodesk%20Installation%20Help/index.html?url=files/GUID-76F2BAD9-39D8-40F0-B60F-699C8A5CD305.htm,topicNumber=d30e3278

    If you look in your deployment directory and use the msi packages instead.

    \\server123\Deployment\Img\x64\<product name><deployment name>.msi and the <deployment name>.mst transform and <tools>gpo.mst

    0
  • I'm trying to figure this out also.  I'm trying to deploy the Autodesk Infrastructure Design Suite Premium product. I thought it would be a simple command line PDQ Deployment package, but it doesn't seem to be working as expected.  The entire suite package is 35GB+ so it's not something I want to be copying down to every workstation for deployment.

    0
  • Can you add two TRANSFORM files in PDQ Deploy as the Autodesk documentation suggest is required?

    I know to add one it is TRANSFORMS=<transform name>.mst

    How would you add a second mst file?  Is the gpo.mst file even necessary for a PDQ deployment?

    0
  • I'm looking to find a fix for this too.

    not sure if its possible to install Autodesk product via PQD Deploy.

    0
  • Try using the /qn instead of /qb. PDQ Deploy (by default) runs packages silently without access to a desktop. /qb attempts to display a status of the installation. /qn = Quiet No Interface - /qb = Quiet Basic Interface.

    If /qb is required then you'll need to use PDQ Deploy 3.1 (currently in beta) and specify the Run As option to "Deploy User (Interactive)"

    0
  • Shane,

    When pointing to a setup.exe file like this when it is part of a large deployment with lots of supporting files, is it necessary to "Include Entire Directory" or is it actually executing the setup.exe remotely (what I want)?  I've attached a screenshot of my deployment.  As you can see the "Install file" setting is pointing at a setup.exe file that resides on a DFS share.  The folder where the setup.exe file resides includes 35GB of additional data that is all part of the Autodesk install deployment.  I do not want to have to copy all of that data to each target workstation if it can be avoided.

    Thanks.

    0
  • Shane,

    I tried using the /qn switch on the default shortcut instead of /qb and it pops up dialogue boxes that require input.  It does not do a full "silent" install.

    0
  • Shane,

    The Autodesk deployment tool creates scripts that can be used by SMS or SCCM (see attached file).  Could the content of these files be leveraged for use by PDQ Deploy somehow?

    0
  • I've trided this out too and want to find a good way to do this.

    As of now I install with a BAT-script that doesnt work to push to clients due to the way the installer doesent wait and continues before the package is installed and mess up all service packs etc that i want to add after.

    call "X:\AutoDESK\Revit2014(x64)\Revit2014(x64).lnk"
    echo SCRIPT WILL PAUSE, CONTINUE WHEN INSTALLER IS DONE 
    pause

    msiexec /update "X:\AutoDESK\Revit2014\Autodesk_Revit_2014-x64_Update1.msp" /passive /norestart

    ...

     

    My next step is to look in the deployment and break out all the dependencies, MS Visual C++ 2005/2008, .NET etc and then try to install the product.

    In the deployment you have RVT2014.msi and RVT2014-yourdeploymentname.mst 

    So something like this: (nothing working yet, just copied from deployment ini files)

    ::3rdParty Prerequisites
    :: Microsoft Visual C++ 2008 SP1 Redistributable (x64)
    Img\3rdParty\x64\VCRedist\2008SP1\vcredist_x64.exe /q
    :: Microsoft Visual C++ 2008 SP1 Redistributable (x64) 9.0.30729.6161
    Img\3rdParty\x64\VCRedist\2008SP1.6161\vcredist_x64.exe /q
    and so on...

    ::Revit
    Img\x64\RVT2014\RVT2014.msi TRANSFORMS="Img\x64\en-us\RVT2014\RVT2014.mst;Img\x64\RVT2014\RVT2014-BDSP2014(x64).mst" ADSK_EULA_STATUS=#1 ADSK_SOURCE_ROOT="Img\" INSTALLDIR="C:\Program Files\Autodesk\" FILESINUSETEXT="" REBOOT=ReallySuppress ADSK_SETUP_EXE=1 /q
    ::AutoCAD
    Img\x64\ACA\ACA.msi TRANSFORMS="Img\x64\en-us\ACA\ACA.mst;Img\x64\ACA\ACA-BDSP2014(x64).mst" ADSK_EULA_STATUS=#1 ADSK_SOURCE_ROOT="Img\" FILESINUSETEXT="" REBOOT=ReallySuppress ADSK_SETUP_EXE=1 /q
    ...
    and so on..

     

    This way i make 1 big deployment with all programs but I dont have to install everything everywhere, I just make a couple of scripts. And then use PDQ to exec the script that looks in the DFS for files so i dont copy down everything. They all have similar dependencies so i dont want them taking up space.

    Thats what I'm going to try anyway...

    0
  • Is it possible to make PDQ Deploy remotely execute the .lnk file that the Autodesk deployment software creates the same way that a logged on user would (but it would run in the background) rather than "copying" the deployment files to the target computer?  It seems like that would solve this problem with the Autodesk deployments

    0
  • If you create a BAT-file in PDQ and run that file on the client PDQ will only copy the BAT file to the client. Try to call the link in the BAT file.

    I install office that way. But instead of a BAT file I'm using the Command step in PDQ. Try both :)

    call "X:\yourdeployment\yourdeployment.lnk"

    0
  • I thought that I tried that and it didn't work.  Maybe not though.  I may have tried calling a BAT file with the command string that is in the .lnk file.  I'll try what you suggest and let you know if it works for me or not.

    0
  • I have tried several different methods of running a batch command or calling a batch file.  They all return "error code 259".

    0
  • I forgot to add...I also deploy MS Office 2007 using a batch file with no issues what so ever.

    0
  • You need to specify the /W switch with the AutoCAD's setup.exe. This will cause the setup process to wait until all children have completed and return a meaningful status code. BTW: the switch for a complete non-GUI silent install is /Q (without a trailing N).

    0
  • Hey guys,

     

    did you ever figure out how to deploy BDSP using PDQ Deploy?  I'm trying to do the same thing, and running into errors as well.

    0
  • @Denis Jedig

    Thanks for the /W suggestion.  I was not aware of that switch and that seems to have fixed my issues when calling a batch file to initiate the install.  Although I need to test a couple more workstations to be sure.

     

    @Chris Lardaro

    See the post by Denis above.  Be sure you are using /q and /w in your command string.  I'm using PDQ to launch a bat file from a DFS share that contains the following command string and it has worked fine on the first couple of workstations.

    \\mydomain.internal\Deploy\Autodesk\C3D2014\Img\setup.exe /w /q /I \\mydomain.internal\Deploy\Autodesk\C3D2014\Img\C3D2014.ini /language en-us

    In my PDQ package I also nest packages to stop our Trend Micro anti-virus services and uninstall some versions of Microsoft Visual Studio C++ prior to installing the Autodesk products.  If the install sees a version of Visual C++ that is newer than the prerequisite the installation will fail.  I also have a package nested to restart the Trend Micro anti-virus services at the end of the package.  See the attachment for a screenshot of my package setup.

    0
  • Hey Pcchenard, do you Push or Pull?  Does it matter?

    0
  • I pull because all my deployments are stored on a DFS share rather than locally on the PDQ Deploy "server".

    0
  • That did it!  It's installing as we speak.  Thanks for your help.  This is going to be a huge help when the 2015 products come out.

    0
  • Great!

    I just tested my deployment on two more workstations it worked fine.  So looks like the /q and /w are the ticket.

    Thanks for that, Denis Jedig.

    0
  • Hmm I'm getting error 259 on my install.  I get a message saying "Completed Revit 2014 installation" install and then it dies.  Running the script manually progresses through   the install. 

     

    My script looks like this:

    \\path\Img\Setup.exe /W /qb /I \\path\Img\deplomentparameters.ini /language en-us

    0
  • Change you /qb to /q

    0
  • Hmm still failing.  Have you pushed out BDSP using PDQ Deploy, or just Acad Civil?  Maybe the multiple MSIs are causing the package to fail.

    0
  • Are you sure you don't have newer versions of the pre-requisites installed than it wants to see?

    0
  • I'm deploying IDSP, but I always make separate deployments for each product in the suite rather than one deployment for everything.

     

    Are you sure there is no anti-virus software running on the target computer?  I was getting error 259 when my anti-virus wasn't stopped prior to deployment.

    There should be a log fine in your Autodesk deployment network location.  Where does the log file say it is failing?

    0
  • I'll try a test computer that doesn't have AV installed and see how it goes.

     

    It's failing at Revit -- 

     

    MSI (s) (1C:E4) [13:19:48:793]: Doing action: InstallInitialize
    MSI (s) (1C:E4) [13:19:48:793]: Machine policy value 'AlwaysInstallElevated' is 0
    MSI (s) (1C:E4) [13:19:48:793]: User policy value 'AlwaysInstallElevated' is 0
    MSI (s) (1C:E4) [13:19:48:793]: BeginTransaction: Locking Server
    MSI (s) (1C:E4) [13:19:48:809]: Transforming table Property.

    MSI (s) (1C:E4) [13:19:48:809]: Transforming table Property.

    MSI (s) (1C:E4) [13:19:48:824]: SRSetRestorePoint skipped for this transaction.
    MSI (s) (1C:E4) [13:19:48:824]: Server not locked: locking for product {7346B4A0-1400-0510-0000-705C0D862004}
    MSI (s) (1C:E4) [13:19:48:934]: Doing action: ai_Store.E3C65CFA_874D_4EDC_808F_64D6BBAC7CD4
    MSI (s) (1C:E4) [13:19:48:934]: Transforming table CustomAction.

    MSI (s) (1C:E4) [13:19:48:934]: Note: 1: 2262 2: CustomAction 3: -2147287038
    MSI (s) (1C:E4) [13:19:48:934]: Transforming table CustomAction.

    MSI (s) (1C:A4) [13:19:48:934]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI62C2.tmp, Entrypoint: AppIndexWrite
    MSI (s) (1C:A4) [13:19:48:934]: Lost connection to custom action server process. Attempting to regenerate.
    MSI (s) (1C:F8) [13:19:48:934]: Generating random cookie.
    MSI (s) (1C:F8) [13:19:48:934]: Created Custom Action Server with PID 6068 (0x17B4).
    MSI (s) (1C:F8) [13:19:49:043]: CA Server Process has terminated.
    MSI (s) (1C:E4) [13:19:49:043]: Note: 1: 1719
    MSI (s) (1C:E4) [13:19:49:043]: Product: Revit 2014 - - Error 1719.The Windows Installer Service could not be accessed. This can occur if the Windows Installer is not correctly installed. Contact your support personnel for assistance.

    0
  • Thank you all VERY much for picking up this thread and trying to come up with a solution.  My apologies for not having been able to take active part since opening it, but I'm grateful especially to @Denis Jedig and @Pcchenard for getting an answer that seems to work for many.

    I, unfortunately, am still having an issue with the deployment (now for BDS 2015).  See attached for a screen capture of my setup, which looks to match others in this post.  Oddly, when I kick off the installation via PDQ, nothing seems to happen on the client side - in other words, the server installation logs are not updated, no Program Files folders are generated, etc.  Basically it seems as though the installer is spinning its wheels trying to get going for an hour before it times out.  I'd be happy to provide C++ versions to ensure that prerequisites are met, but it doesn't even seem to be getting to that point.

    To confirm, installing locally via the following shortcut is successful (as is deploying all other packages via PDQ Deploy):

    "\\localserver\Autodesk\BDS Premium 2015\Img\Setup.exe" /qb /I \\localserver\Autodesk\BDS Premium 2015\Img\BDS 2015.ini /language en-us

    Any suggestions on what might be going on?  Thanks again!

    0
  • Maybe add quotation marks around the ini portion?  It's possible that it's not liking the space between BDS and 2015

    0

Please sign in to leave a comment.

Didn't find what you were looking for?

New post