java icon missing after install

Comments

5 comments

  • TonsOFun

    this only happens using pdq deploy? that's strange indeed. 

    i'm using the same msi you're grabbing from the install (Appdata), and have both 32-bit and 64-bit functioning fine. 

    And just checked the Java icon in Control Panel, and it's there and functioning as well. 

    I used the package library as a reference for mine. The instructions in that package closes any opened browser at the time of install. 

    Perhaps someone is leaving theirs on while you're attempting to install? 

    0
    Comment actions Permalink
  • itdept

    It's not 100% of the time. I tested it on my pc first. I had my browser closed. It installed & I saw the right version listed in add / remove programs but the icon in control panel went missing. Wouldn't come back no matter how many times I uninstalled & then redeploy with pdq. Had to manually install java for the icon to come back. This isn't the first time I've seen this happen.

    I then tried 2 other computers& they worked fine. So not sure...

    0
    Comment actions Permalink
  • TonsOFun

    hmm... i did some research.

     try launching the actual program itself. 

    C:\Program Files\Java\jre6\bin\javacpl.exe

    or C:\program files (x86)

    depending on your version, it should be there. 

    as of JRE7, only the 64-bit will appear. 32-bit is missing. however, the 64-bit icon still appears in control panel.

    64-bit OS will only appear in C:\Program Files\Java\jre7\bin

    Not sure if this was by design, but i looked in my C:\Program Files (x86)\java\jre7\bin and did not find the executable mentioned above. 

    in fact, the bin folder was completely empty. -_-

    0
    Comment actions Permalink
  • SelfMan

    If you are not using the installer from PDQ Deploy Pro Repository, you should allways download the offline installer.

    The current JRE7u11 versions are located here: JRE7u11x86 http://javadl.sun.com/webapps/download/AutoDL?BundleId=73141 JRE7u11x64 http://javadl.sun.com/webapps/download/AutoDL?BundleId=73143

    0
    Comment actions Permalink
  • itdept

    I already have the icon back. I had to un-install & re-install the manual way for things to come back to normal.

    This is a 32bit OS win 7 & the icon does show up when nothing goes wrong. When I was missing the icon I did go to the CPL file in program files & ran it from there. It was just missing from control panel.

    I downloaded the offline installer from java.com.

    I just wanted to see if anyone else had noticed this issue. It's fine. I know how to fix it but wasn't sure if I was the only one or not. It also doesn't happen to all computers. Just beware if it comes up again by someone else.

    0
    Comment actions Permalink

Please sign in to leave a comment.