PDQ Deploy fails to remote install application that installs locally

Comments

5 comments

  • Shane Corellian

    Thanks for the screenshots and props for testing the command line switches via the Run window.

    When you ran this locally did ANY window (other than a UAC confirmation) pop up? A common window (even in some "silent" installations) is either a confirmation window or an Installation complete window. 

    Are there multiple files that are needed for the installation? If so, are they included in the package? Extra files are usually included by clicking the Include Entire Directory option but they can also be added via the Additional Files drop down.

    0
    Comment actions Permalink
  • Sbrown

    Shane, thanks for the reply.  When run locally I did see a progress bar display but that was it.  There were no confirmations or installation complete windows.  The only file needed is the executable.  I was made aware of another option to use, "/verysilent" which will not even show the progress bar.  I could try that?

    0
    Comment actions Permalink
  • Shane Corellian

    Definitely try the /versilent parameter. Sometimes even a progress bar can prevent a windows service (the PDQDeployRunner-x service installs the product on the targets) from finishing a deployment.

    0
    Comment actions Permalink
  • Sbrown

    I tried the /verysilent option.  When run on the local machine it does not show the progress bar or anything else.  I then uninstalled the program and tried using PDQ with the new option and it did the same thing, hang with a running status.  Anything else I could try?

    I did not know about PDQDeployRunner-1 service.  It is currently started on that machine.  The PDQ console is showing a runtime of 9 minutes and still running so I will now abort the deployment.  FYI, when run locally it takes about 20 seconds to install.

    0
    Comment actions Permalink
  • Sbrown

    I found a workaround.  I created a batch file that does the install then pushed the batch file using PDQ and it worked.  Thanks for your time.

    0
    Comment actions Permalink

Please sign in to leave a comment.