PDQ Deploy 15 R4 - Brutally slow when going through all deployments

Comments

4 comments

  • Monica KVH

    Loading all deployments can slow down when you have a lot of old deployments in the list. An easier way to tackle this might be to set up a cleanup timer, which will delete deployment records when they're older than the specified age in days.

    Options > Preferences > Deployments > Cleanup

    If you have it set to 0, it will keep deployments until they're manually deleted, which can cause slow loading and probably crashing like you're experiencing. Consider the number of endpoints you deploy to, how often you check PDQ Deploy for deployment statuses, and the frequency at which deployments occur, and adjust cleanup age accordingly. If you have to keep deployment records for a certain period of time for auditing purposes, use that as the age.

    Personally, I use 30 day cleanup for ~200 PCs receiving daily and heartbeat deployments and All Deployments takes 1-2 seconds to load. (Amounting to about 1000 deployment IDs)

    Hope that helps!

    2
    Comment actions Permalink
  • sean johnson

    That's a good tip, i set it down to 2 weeks to prevent it from stacking up so high. 

    0
    Comment actions Permalink
  • Benoit Heylens

    I manage a 1600+ computers and 400+ servers list and it's painfully slow and it often crashes (what he previously did not do). Has something changed in the way the client acts ?

    I often have to go to the server to manually check if the service is alive (but it is, and nothing seems wrong on the server side).

    It could be anything, even an update on my graphical drivers, but I did not have this behavior before.

    Regards,

    Ben

    0
    Comment actions Permalink
  • Colby Bouma

    I believe Support has customer builds where this is fixed. support@pdq.com

    0
    Comment actions Permalink

Please sign in to leave a comment.